Comment trouver des valeurs en double dans Excel à l’aide de VLOOKUP ?

Afficher la discussion

Améliorer l’article

Enregistrer l’article

J’aime l’article

Afficher la discussion

Améliorer l’article

Enregistrer l’article

J’aime l’article

Dans cet article, nous verrons comment nous pouvons utiliser VLOOKUP pour trouver des valeurs en double dans Excel.

Pour ce faire, suivez les étapes ci-dessous :

  • Créons deux colonnes de section différente pour vérifier la formule VLOOKUP sur les colonnes :
List

Création de deux colonnes

  • Voici la formule que nous allons utiliser :
=VLOOKUP(List1,List2,TRUE,FALSE)
  • Dans cette formule, les noms de la Liste-1 seront recherchés dans la Liste-2. S’il existe un nom en double, la formule renverra le nom de List-1. Regardons attentivement notre exemple pour une meilleure clarification.
  • En C2 nous écrirons cette formule =RECHERCHEV(A2:A10,B2:B10,VRAI,FAUX) puis appuyez sur Entrée.

img2

  • Maintenant, nous allons voir ce résultat :
img3

Ici Himesh est une valeur en double

  • Ici, le Himesh est trouvé parce que la fonction VLOOKUP recherche ce nom de la section A à la section B. Lorsque le même nom est trouvé, il affichera le résultat de la section A.
  • Maintenant, faites glisser la liste et voyez toutes les valeurs.
img4

Ici, nous faisons glisser les cellules formulées

  • Les résultats #N/A sont trouvés car, dans ces cellules particulières, les noms de la colonne A ne se trouvent pas dans la colonne B.
  • Dans la colonne Résultat, vous voyez un total de 2 valeurs en double ( Himesh, Pragya). Les valeurs #N/A représentent les valeurs uniques de la section A de la colonne.

Utilisation de VLOOKUP pour trouver des valeurs en double dans deux feuilles de calcul Excel

Nous pouvons également utiliser VLOOKUP pour trouver des valeurs en double entre deux feuilles de calcul Excel. Pour ce faire, suivez les étapes ci-dessous :

  • Créez deux classeurs Excel Section A et Section B.
img5

Deux cahiers

  • Dans le B2 de la section B, tapez le code ci-dessous et appuyez sur Entrée : –
=IF(ISERROR(VLOOKUP(A2,'Section A'!A1:A10,1,0)),"Unique","Duplicate")
img6

Section A et section B sur différents cahiers

Utilisation de VLOOKUP pour trouver des doublons dans deux classeurs d’Excel

Nous pouvons également utiliser VLOOKUP pour trouver des valeurs en double entre deux classeurs Excel. Pour ce faire, suivez les étapes ci-dessous :

  • Maintenant, nous créons une nouvelle section A dans un nouveau classeur avec des valeurs différentes.
img7

Nouveau classeur

  • Et dans notre classeur principal sur lequel nous travaillions (dans notre dernier exemple), créez une autre feuille de calcul intitulée Feuille 1 et créez à nouveau une liste de produits.
img7

Un autre classeur nommé Sheet1

  • Maintenant, dans la cellule C2 de Sheet1, notez la formule suivante et appuyez sur Entrée.
=IF(ISERROR(VLOOKUP(B2,[VL]Section A!$A$2:$A$10,1,0)),"Unique", "Duplicate")
  • Vous obtiendrez le résultat comme Unique car la valeur n’existe pas dans la section A.
img8

Résultat

  • Maintenant, faites glisser vers le bas la cellule formulée pour voir le résultat de toute la colonne.

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *